Keep Node.js update to install wdio

 

When install Visual Studio 2015, you might select Node.js in the wizard. It will work smoothly to install gulp, angular etc.

2016-9-8-0

However, when you are going to install wdio utility of webdriverio by “npm install wdio”, you might experience the following error.

2016-9-8-1

Apparently, wdio is dependent on fibers; there is error when node-gyp is trying to compile fibers. Follow node-gyp windows installation document to install python 2.7 etc on windows while the issue will still be persistent. The reason of this issue is because the node installed together with visual studio is v0.12.2, while “If you are running NodeJS version 4.x, 5.x, or 6.x on Linux, OS X, or Windows (7 or later) then you should be able to install fibers from npm just fine.” documented in fibers, install a latest node will solve the problem. For more node-gyp installation on windows, you might refer to Use local-npm for offline NPM package installation which has covered most scenarios.

hflbigsle-1024x430